Jump to content

Check us out:

- - - - -

I think my droid x kicked the bucket?


  • You cannot reply to this topic
No replies to this topic

#1 OFFLINE   tay97gst

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 14 July 2012 - 09:06 AM

Ok well, my phone died the other day and when i tried to charge it i got the bootloader 30.04 message that said battery low. So i ghetto charged the battery. After charging the battery I tried to start the phone and it is just stuck at the red motorola logo. It will not go away from this unless i pull the battery. I can get into bootloader by holding down the volume camera and power but cant get into recovery by holding home and power.I googled what was going on and people said sbf the phone so i did the .621 because i had the update installed. Everything installed fine but after reboot it's having the same exact problem.. I have never messed with the phone before so its all stock prior to this happening. I did notice the water indicator was red on the back too. Would this cause the symptoms im having? I think the phone is completely dead and have tried everything. I dont know much about the droid world but need some help, thanks.

Remove Advertisements Sponsored Links

    MyDroidWorld.com







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users