Jump to content

Check us out:

- - - - -

Google Maps Fix (Froyo)


155 replies to this topic

#1 OFFLINE   zone117x

    Junior Droid

  • Members
  • PipPip
  • 20 posts

Posted 06 June 2010 - 11:11 PM

Your symptoms should be something like this: Google Maps won't update (or install) from the Market, but you see it in your apps and it works fine.

Using ADB run the following commands:
adb.exe uninstall com.google.android.apps.maps

adb.exe shell rm /system/app/Maps.apk

Now try to install Google Maps from the Market, it should work.

Guide on using ADB

If this doesn't work for you then try the fixes in the comments below!

In case you deleted your Maps.apk file and need it back, olta777 uploaded it

Please Login HERE or Register HERE to see this link!

.



___________________________



Here are maps fixes collected by mrZoSo...Thank you!!!!!

So people don't have to scoure through the all he posts here, I put the 3 fixes that have been successful at fixing the maps issue.

Using adb

** Make sure android sdk is installed properly - How To: adb for Windows the Easy Way
** Make sure phone has USB debugging on.

Plug phone to USB
Open command prompt
Type this (DO NOT TYPE adb shell unless noted):

adb kill-server
adb root
adb remount
adb shell rm /system/app/Maps.apk
adb uninstall com.google.android.apps.maps


If you get a not found error after you type the first one in, then the sdk/tools is not in the windows path correctly. Double check the sdk and that the path is correct.

You should now be able to install Maps from the Market.


Using Root Explorer

Do a search for maps
Delete:
/data/app/com.google.android.apps.maps-1.apk -you might not have this entry, it's OK
/data/data/com.google.android.apps.maps

If you see /system/app/Maps.apk, move it out to your sdcard, your going to need it soon.

Reboot phone
Install Maps using the apk just moved to sdcard
Run maps and play in it for a minute, join Latitude also from within Maps, just to make sure it works and close it.
Go in to Settings>Applications>Manage applications>All, tap on Maps, tap Clear data, tap Uninstall
Go to Market and re-installed from there.
When going in to Maps, you should get a Login failed- that's OK, click on join Latitude now you should see a Notification(in Notification bar up top) asking for permission, accept it and your good to go now.


Editing packages.xml

Now after my install of Froyo: Maps wasn't accessible, I couldn't install it from the market, and wasn't in the Settings->Applications->Manage applications menu.
I tried running zone117x's code in the adb and I could only get the second line to go through - because Maps wasn't really installed. However, some artifacts were left over from the recovery image that prevent the install from market.
Once you mount your device with read-write access (with the adb) and give adb root privileges (once again, with the adb), you must edit the /data/system/packages.xml file. There is an entry that looks something like:
<shared-user name="com.google.android.apps.maps" userId="10028">

<sigs count="1">

<cert index="13" />

</sigs>

<perms>

<item name="com.android.launcher.permission.INSTALL_SHORTCUT" />

<item name="android.permission.USE_CREDENTIALS" />

<item name="android.permission.GET_TASKS" />

<item name="android.permission.WRITE_EXTERNAL_STORAGE" />

<item name="android.permission.ACCESS_WIFI_STATE" />

<item name="android.permission.ACCESS_COARSE_LOCATION" />

<item name="android.permission.GET_ACCOUNTS" />

<item name="android.permission.READ_CONTACTS" />

<item name="android.permission.CALL_PHONE" />

<item name="com.google.android.apps.maps.permission.PUSH_MESSAGE" />

<item name="android.permission.WRITE_CONTACTS" />

<item name="com.google.android.googleapps.permission.GOOGLE_AUTH" />

<item name="com.google.android.providers.gsf.permission.READ_GSERVICES" />

<item name="android.permission.DISABLE_KEYGUARD" />

<item name="android.permission.READ_PHONE_STATE" />

<item name="com.google.android.googleapps.permission.GOOGLE_AUTH.local" />

<item name="android.permission.INTERNET" />

<item name="android.permission.ACCESS_FINE_LOCATION" />

<item name="android.permission.MANAGE_ACCOUNTS" />

<item name="android.permission.VIBRATE" />

<item name="android.permission.RECORD_AUDIO" />

<item name="android.permission.ACCESS_NETWORK_STATE" />

<item name="android.permission.WAKE_LOCK" />

</perms>

</shared-user>
Remove this entry. Put the packages.xml file back on to your Droid and then restart. Then you should be able to install Maps from the market.
Here is rough step by step guide
Note: I am using a linux machine, hence no .exe after 'adb'. The commands should be very similar in Windows.
adb remount

adb root

adb shell rm /data/app/Maps.apk

adb pull /data/system/packages.xml packages.xml

(now edit packages.xml with your favorite text editor and remove the maps entry)

adb push packages.xml /data/system/packages.xml

(then shutdown and start back up!)
Just remember that the packages.xml file will end up in whatever folder you are executing the

adb command from.

Edited by olta777, 10 June 2010 - 02:04 PM.
added mrZoSo fix


Remove Advertisements Sponsored Links

    MyDroidWorld.com



#2 OFFLINE   mrZoSo

    Droid

  • Members
  • 131 posts
  • Device:Moto Droid

Posted 07 June 2010 - 01:50 AM

I finally did get it to install through the Market.
Using Root Explorer I did a search for maps
I deleted:
/data/app/com.google.android.apps.maps-1.apk -you might not have this entry, it's OK
/data/data/com.google.android.apps.maps

If you see /system/app/Maps.apk, move it out to your sdcard

Rebooted phone
Installed Maps using the apk just moved to sdcard
I ran maps and played in it for a minute, joined Latitude also from within Maps, just to make sure it worked and closed it.
Then went in to Settings>Applications>Manage applications>All, tap on Maps, tap Clear data, tap Uninstall
Went to Market and re-installed from there.
Went in to Maps, got Login failed- that's OK, clicked on join Latitude now you should see a Notification(in Notification bar up top) asking for permission, accept it and your good to go now.

I did notice that after it installed through Market, Maps.apk does not show in /system/app or anywhere else, the only apk showing is /data/app/com.google.android.apps.maps-1.apk

Hope this helps, might have to do it a couple times, not sure. Seems to me the maps that is installed in the Froyo ROM is scrambled a little? for lack of better words, who knows,,,heh

EDIT: Verified this method worked on the second release of Froyo as well.

Good Luck

Edited by mrZoSo, 09 June 2010 - 11:10 AM.
verified working on 2nd release of Froyo


#3 OFFLINE   wirehead

    MDW Noob

  • Members
  • Pip
  • 2 posts
  • Device:Motorola DROID

Posted 07 June 2010 - 02:09 AM

At least previously they worked, just without Latitude.

My own fault for not backing up Maps.apk, but now I have *NO* maps at all.

#4 OFFLINE   tanked

    Junior Droid

  • Members
  • PipPip
  • 26 posts
  • Device:Droid Charge

Posted 07 June 2010 - 03:38 AM

Hey guys, let me first off say that this website is great!

Second, I'll share my fix.

Now after my install of Froyo: Maps wasn't accessible, I couldn't install it from the market, and wasn't in the Settings->Applications->Manage applications menu.

I tried running zone117x's code in the adb and I could only get the second line to go through - because Maps wasn't really installed. However, some artifacts were left over from the recovery image that prevent the install from market.

Once you mount your device with read-write access (with the adb) and give adb root privileges (once again, with the adb), you must edit the /data/system/packages.xml file. There is an entry that looks something like:
<shared-user name="com.google.android.apps.maps" userId="10028">

<sigs count="1">

<cert index="13" />

</sigs>

<perms>

<item name="com.android.launcher.permission.INSTALL_SHORTCUT" />

<item name="android.permission.USE_CREDENTIALS" />

<item name="android.permission.GET_TASKS" />

<item name="android.permission.WRITE_EXTERNAL_STORAGE" />

<item name="android.permission.ACCESS_WIFI_STATE" />

<item name="android.permission.ACCESS_COARSE_LOCATION" />

<item name="android.permission.GET_ACCOUNTS" />

<item name="android.permission.READ_CONTACTS" />

<item name="android.permission.CALL_PHONE" />

<item name="com.google.android.apps.maps.permission.PUSH_MESSAGE" />

<item name="android.permission.WRITE_CONTACTS" />

<item name="com.google.android.googleapps.permission.GOOGLE_AUTH" />

<item name="com.google.android.providers.gsf.permission.READ_GSERVICES" />

<item name="android.permission.DISABLE_KEYGUARD" />

<item name="android.permission.READ_PHONE_STATE" />

<item name="com.google.android.googleapps.permission.GOOGLE_AUTH.local" />

<item name="android.permission.INTERNET" />

<item name="android.permission.ACCESS_FINE_LOCATION" />

<item name="android.permission.MANAGE_ACCOUNTS" />

<item name="android.permission.VIBRATE" />

<item name="android.permission.RECORD_AUDIO" />

<item name="android.permission.ACCESS_NETWORK_STATE" />

<item name="android.permission.WAKE_LOCK" />

</perms>

</shared-user>

Remove this entry. Put the packages.xml file back on to your Droid and then restart. Then you should be able to install Maps from the market.

Here is rough step by step guide
Note: I am using a linux machine, hence no .exe after 'adb'. The commands should be very similar in Windows.
adb remount

adb root

adb shell rm /data/app/Maps.apk

adb pull /data/system/packages.xml packages.xml

(now edit packages.xml with your favorite text editor and remove the maps entry)

adb push packages.xml /data/system/packages.xml

(then shutdown and start back up!)

Just remember that the packages.xml file will end up in whatever folder you are executing the adb command from.

Let me know if this works for anyone else :)

Edited by tanked, 07 June 2010 - 06:03 PM.


#5 OFFLINE   RANDYRKELLY

    Android Master

  • Members
  • 992 posts
  • Twitter:twitter.com/rrkmdw
  • Device:Moto Droid

Posted 07 June 2010 - 06:30 AM

Thanks for this work around. And Welcome to MyDroidWorld. See you in the forums. Also #mydroidworld irc channel

tanked said:

Hey guys, let me first off say that this website is great!

Second, I'll share my fix.

Now after my install of Froyo: Maps wasn't accessible, I couldn't install it from the market, and wasn't in the Settings->Applications->Manage applications menu.

I tried running zone117x's code in the adb and I could only get the second line to go through - because Maps wasn't really installed. However, some artifacts were left over from the recovery image that prevent the install from market.

Once you mount your device with read-write access (with the adb) and give adb root privileges (once again, with the adb), you must edit the /data/system/packages.xml file. There is an entry that looks something like:
<shared-user name="com.google.android.apps.maps" userId="10028">
<sigs count="1">
<cert index="13" />
</sigs>
<perms>
<item name="com.android.launcher.permission.INSTALL_SHORTCUT" />
<item name="android.permission.USE_CREDENTIALS" />
<item name="android.permission.GET_TASKS" />
<item name="android.permission.WRITE_EXTERNAL_STORAGE" />
<item name="android.permission.ACCESS_WIFI_STATE" />
<item name="android.permission.ACCESS_COARSE_LOCATION" />
<item name="android.permission.GET_ACCOUNTS" />
<item name="android.permission.READ_CONTACTS" />
<item name="android.permission.CALL_PHONE" />
<item name="com.google.android.apps.maps.permission.PUSH_MESSAGE" />
<item name="android.permission.WRITE_CONTACTS" />
<item name="com.google.android.googleapps.permission.GOOGLE_AUTH" />
<item name="com.google.android.providers.gsf.permission.READ_GSERVICES" />
<item name="android.permission.DISABLE_KEYGUARD" />
<item name="android.permission.READ_PHONE_STATE" />
<item name="com.google.android.googleapps.permission.GOOGLE_AUTH.local" />
<item name="android.permission.INTERNET" />
<item name="android.permission.ACCESS_FINE_LOCATION" />
<item name="android.permission.MANAGE_ACCOUNTS" />
<item name="android.permission.VIBRATE" />
<item name="android.permission.RECORD_AUDIO" />
<item name="android.permission.ACCESS_NETWORK_STATE" />
<item name="android.permission.WAKE_LOCK" />
</perms>
</shared-user>

Remove this entry. Put the packages.xml file back on to your Droid and then restart. Then you should be able to install Maps from the market.

Here is rough step by step guide
Note: I am using a linux machine, hence no .exe after 'adb'. The commands should be very similar in Windows.
adb remount
adb root
adb shell rm /data/app/Maps.apk
adb pull /data/system/packages.xml packages.xml
(now edit packages.xml with your favorite text editor and remove the maps entry)
adb push packages.xml /data/system/packages.xml
adb reboot

Just remember that the packages.xml file will end up in whatever folder you are executing the adb command from.

Let me know if this works for anyone else :)

Posted Image

:confusedIf Your Ever In A Bind And Can't Fix Your Droid, Just Gtalk Or Email Me RANDYRKELLY@GMAIL.COM:fire


#6 OFFLINE   jb13

    MDW Noob

  • Members
  • Pip
  • 2 posts
  • Device:moto droid

Posted 07 June 2010 - 07:03 AM

can i run this same code through terminal emulator..or is there another code i can run using terminal emulator right on my phone

#7 OFFLINE   breakerfall

    Junior Droid

  • Members
  • PipPip
  • 14 posts

Posted 07 June 2010 - 08:26 AM

mrZoSo said:

This didn't work for me. The first line gives me "Failure" as a result.

EDIT: I finally did get it to install through the Market though.
Using Root Explorer I did a search for maps
I deleted:
/data/app/com.google.android.apps.maps-1.apk
/data/data/com.google.android.apps.maps

If you see it in /system/app/Maps.apk, move it out to your sdcard

Rebooted phone
Installed Maps using the apk just moved to sdcard
I ran maps and played in it for a minute just to make sure it worked and closed it.
Then went in to Settings>Applications>Manage applications>All, tap on Maps, tap Clear data, tap Uninstall
Went to Market and re-installed from there.

I did notice that after it installed through Market, Maps.apk does not show in /system/app or anywhere else, the only apk showing is /data/app/com.google.android.apps.maps-1.apk

Hope this helps, might have to do it a couple times, not sure. Seems to me the maps that is installed in the Froyo ROM is scrambled a little? for better words, who knows,,,heh

Good Luck
this craziness worked for me.

#8 OFFLINE   mozicodo

    MDW Noob

  • Members
  • Pip
  • 5 posts
  • Twitter:http://twitter.com/mozicodo
  • Device:Droid

Posted 07 June 2010 - 09:40 AM

Excellent. The packages.xml fix worked for me.

#9 OFFLINE   tanked

    Junior Droid

  • Members
  • PipPip
  • 26 posts
  • Device:Droid Charge

Posted 07 June 2010 - 09:43 AM

:D Glad it worked for you!

#10 OFFLINE   mrZoSo

    Droid

  • Members
  • 131 posts
  • Device:Moto Droid

Posted 07 June 2010 - 10:52 AM

tanked said:

Hey guys, let me first off say that this website is great!

Second, I'll share my fix.

Now after my install of Froyo: Maps wasn't accessible, I couldn't install it from the market, and wasn't in the Settings->Applications->Manage applications menu.
Hmm, mine worked and was in Manage applications. I wonder if that has to do with what package was used to install Froyo, ClockWorkRecovery or SPRecovery. I installed with CW when I fixed maps. I did previously install Froyo using SP but never even thought of the maps thing at that time, wish I did.

Well, atleast there are ways to fix it now ;)

wirehead said:

At least previously they worked, just without Latitude.

My own fault for not backing up Maps.apk, but now I have *NO* maps at all.
You can get it here, if you still need it.
http://www.mydroidwo...t-q-thread.html

Edited by mrZoSo, 07 June 2010 - 10:56 AM.


#11 OFFLINE   tanked

    Junior Droid

  • Members
  • PipPip
  • 26 posts
  • Device:Droid Charge

Posted 07 June 2010 - 10:59 AM

It could, I installed via SP - which would support your theory.

#12 OFFLINE   PoppaBearDriod

    Junior Droid

  • Members
  • PipPipPip
  • 55 posts
  • Twitter:@poppabeardray
  • Device:Moto Droid

Posted 07 June 2010 - 11:09 AM

Weird, I never had this problem, I just did a double wipe of data and cache and after all my other apps downloaded I manually downloaded maps and it worked.

#13 OFFLINE   mrZoSo

    Droid

  • Members
  • 131 posts
  • Device:Moto Droid

Posted 07 June 2010 - 11:25 AM

PoppaBearDriod said:

Weird, I never had this problem, I just did a double wipe of data and cache and after all my other apps downloaded I manually downloaded maps and it worked.
Did you do the wipe of data and cache after the Froyo install?

Most know that doing a wipe before installing a ROM is pretty much a given, I would hope ;)

#14 OFFLINE   fscalzo

    Junior Droid

  • Members
  • PipPip
  • 18 posts

Posted 07 June 2010 - 12:09 PM

Maps seems to work for me but I can not update, it in shows in the apps, it launches, but it does not show installed in market and when i try to install it it fails. I tried the root delete and reinstall but that did not seem to work.

#15 OFFLINE   tanked

    Junior Droid

  • Members
  • PipPip
  • 26 posts
  • Device:Droid Charge

Posted 07 June 2010 - 12:16 PM

fscalzo said:

Maps seems to work for me but I can not update, it in shows in the apps, it launches, but it does not show installed in market and when i try to install it it fails. I tried the root delete and reinstall but that did not seem to work.

Try removing the Maps entry from the packages.xml file - that should fix your problem.

#16 OFFLINE   gnath9

    Droid

  • Members
  • 117 posts
  • Device:Droid

Posted 07 June 2010 - 12:22 PM

what is it in the new maps that make it so much better ?
Mine seems to work just fine navigating and all. It just wont update and does not show installed but is listed uner my downloads in the market.

#17 OFFLINE   diverbelow

    Junior Droid

  • Members
  • PipPipPip
  • 84 posts

Posted 07 June 2010 - 12:29 PM

tanked said:

Hey guys, let me first off say that this website is great!

Second, I'll share my fix.

Now after my install of Froyo: Maps wasn't accessible, I couldn't install it from the market, and wasn't in the Settings->Applications->Manage applications menu.

I tried running zone117x's code in the adb and I could only get the second line to go through - because Maps wasn't really installed. However, some artifacts were left over from the recovery image that prevent the install from market.

Once you mount your device with read-write access (with the adb) and give adb root privileges (once again, with the adb), you must edit the /data/system/packages.xml file. There is an entry that looks something like:
<shared-user name="com.google.android.apps.maps" userId="10028">
<sigs count="1">
<cert index="13" />
</sigs>
<perms>
<item name="com.android.launcher.permission.INSTALL_SHORTCUT" />
<item name="android.permission.USE_CREDENTIALS" />
<item name="android.permission.GET_TASKS" />
<item name="android.permission.WRITE_EXTERNAL_STORAGE" />
<item name="android.permission.ACCESS_WIFI_STATE" />
<item name="android.permission.ACCESS_COARSE_LOCATION" />
<item name="android.permission.GET_ACCOUNTS" />
<item name="android.permission.READ_CONTACTS" />
<item name="android.permission.CALL_PHONE" />
<item name="com.google.android.apps.maps.permission.PUSH_MESSAGE" />
<item name="android.permission.WRITE_CONTACTS" />
<item name="com.google.android.googleapps.permission.GOOGLE_AUTH" />
<item name="com.google.android.providers.gsf.permission.READ_GSERVICES" />
<item name="android.permission.DISABLE_KEYGUARD" />
<item name="android.permission.READ_PHONE_STATE" />
<item name="com.google.android.googleapps.permission.GOOGLE_AUTH.local" />
<item name="android.permission.INTERNET" />
<item name="android.permission.ACCESS_FINE_LOCATION" />
<item name="android.permission.MANAGE_ACCOUNTS" />
<item name="android.permission.VIBRATE" />
<item name="android.permission.RECORD_AUDIO" />
<item name="android.permission.ACCESS_NETWORK_STATE" />
<item name="android.permission.WAKE_LOCK" />
</perms>
</shared-user>

Remove this entry. Put the packages.xml file back on to your Droid and then restart. Then you should be able to install Maps from the market.

Here is rough step by step guide
Note: I am using a linux machine, hence no .exe after 'adb'. The commands should be very similar in Windows.
adb remount
adb root
adb shell rm /data/app/Maps.apk
adb pull /data/system/packages.xml packages.xml
(now edit packages.xml with your favorite text editor and remove the maps entry)
adb push packages.xml /data/system/packages.xml
adb reboot

Just remember that the packages.xml file will end up in whatever folder you are executing the adb command from.

Let me know if this works for anyone else :)

I tried the first couple of steps to get my maps updated from the Market and had no luck.

Since I am currently at work, and did not want to wait until I got home to install adb on my Ubuntu machine, so I used root explorer to move over packages.xml to my SD card, and edit the file as mentioned above, then copy back the file and rebooted.
Funny thing that my phone did was to resign in, and all my shortcuts where gone each of the home screens. But the good news is that I was able to get maps installed through the market!

Thanks!

#18 OFFLINE   mrZoSo

    Droid

  • Members
  • 131 posts
  • Device:Moto Droid

Posted 07 June 2010 - 12:38 PM

Yep, when them icons disappear, that's a good sign! I noticed that too.

Quote

what is it in the new maps that make it so much better ?
Mine seems to work just fine navigating and all. It just wont update and does not show installed but is listed uner my downloads in the market.
It's the same version of maps so there's no difference, but it probably won't update(I'm assuming), when an update is available since it won't install from the market. So we're trying to solve the install from market issue here, and also for some, maps and latitude don't work. ;)

#19 OFFLINE   nabilalk

    Junior Droid

  • Members
  • PipPipPip
  • 58 posts
  • Device:Moto Droid

Posted 07 June 2010 - 12:45 PM

Thanks for the guide. Just to be clear:

you start to delete the entry @ <shared-user name="com.google.android.apps.maps" userId="10028">

and stop deleting @ </shared-user>

Is that correct?

#20 OFFLINE   tanked

    Junior Droid

  • Members
  • PipPip
  • 26 posts
  • Device:Droid Charge

Posted 07 June 2010 - 12:50 PM

You've got it - it's inclusive. So you delete the shared-user tags too.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users