Jump to content


Photo
- - - - -

Trying to add sound to Boot animation in froyo..need help


  • Please log in to reply
8 replies to this topic

#1 rickou812

rickou812

    Junior Droid

  • Members
  • PipPip
  • 18 posts
  • Device:MotoDroid

Posted 06 August 2010 - 11:05 AM

I am trying to add sound to my custom boot animation.
This is what I have done so far:

Added to init.rc
###Bootsound - Safe to Delete: Start ###

service bootsound /system/bin/bootsound
        user media
        group audio
        disabled
        oneshot

on property:init.svc.bootanim=running   # to correct timing
        start bootsound

on property:dev.bootcomplete=1
        stop bootsound
### Bootsound - Safe to Delete: End ###

Created bootsound in /system/bin
#!/system/bin/sh
#bootsound - plays a sound at boot

bprop=/system/build.prop
grepprop() { x=`grep "^$1=" $bprop | head -n 1`; echo $x | cut -d = -f 2; }

play=`grepprop "ro.config.play.bootsound"`

if [ "$play" = "1" ]; then
        stagefright -a -o /system/media/android_audio.mp3
fi
exit 0

Added to build.prop
### Safe to Delete: Start ###
ro.config.play.bootsound=1
### Safe to Delete: End ###

And of course added the android_audio.mp3 file to /system/media

No luck, can anyone spot what I may have missed?

Thanks

# Advertisement

Advertisement

Posted Today, 12:54 PM



#2 HarshReality

HarshReality

    Droid

  • Members
  • 140 posts
  • Device:Motorola Droid

Posted 06 August 2010 - 05:58 PM

I gotta ask.. PLEASE say your working this for the Droid. I was under the impression this was Incredible only and it was kernel oriented which is why the D1 wouldnt work. Of course looking at Incredible's file system there is no reference in build.prop or init.d that I can find.

Edited by HarshReality, 06 August 2010 - 07:50 PM.

I am the MASTER of the run-on sentence!

#3 rickou812

rickou812

    Junior Droid

  • Members
  • PipPip
  • 18 posts
  • Device:MotoDroid

Posted 06 August 2010 - 08:37 PM

I gotta ask.. PLEASE say your working this for the Droid. I was under the impression this was Incredible only and it was kernel oriented which is why the D1 wouldnt work. Of course looking at Incredible's file system there is no reference in build.prop or init.d that I can find.


Yes, I am trying to get it to work on the Droid, but not having much luck thus far. But I am positive someone with more android knowledge can figure it out.

#4 HarshReality

HarshReality

    Droid

  • Members
  • 140 posts
  • Device:Motorola Droid

Posted 07 August 2010 - 05:40 AM

Honestly this has been pondered over for some time and asked in the forums. Your post is the first actual near in depth effort I have seen however short of typical small talk.
I am the MASTER of the run-on sentence!

#5 hellrazer1976

hellrazer1976

    Droid

  • Members
  • 129 posts
  • Device:moto droid

Posted 08 August 2010 - 09:22 PM

I see you are using a .mp3 the system uses .ogg I don't know if that matters but I got a custom sound file in both mp3 and ogg and my ringtone / alerts only work on ogg

#6 rickou812

rickou812

    Junior Droid

  • Members
  • PipPip
  • 18 posts
  • Device:MotoDroid

Posted 08 August 2010 - 09:33 PM

I see you are using a .mp3 the system uses .ogg I don't know if that matters but I got a custom sound file in both mp3 and ogg and my ringtone / alerts only work on ogg


I'll give it a go and see..

Thanks

#7 HarshReality

HarshReality

    Droid

  • Members
  • 140 posts
  • Device:Motorola Droid

Posted 09 August 2010 - 03:49 PM

Any luck Rick?
I am the MASTER of the run-on sentence!

#8 rickou812

rickou812

    Junior Droid

  • Members
  • PipPip
  • 18 posts
  • Device:MotoDroid

Posted 09 August 2010 - 03:56 PM

Any luck Rick?


Nope, not yet, I posted a question on a android developers forum to see if I can get some assistance.

#9 hellrazer1976

hellrazer1976

    Droid

  • Members
  • 129 posts
  • Device:moto droid

Posted 09 August 2010 - 11:29 PM

well it was worth the shot




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users